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1. Data import and manipulation 
There are many ways to import data into IRTPRO for analysis. In this chapter, we briefly 
describe procedures for data-import from three commonly used formats: the .sav file format 
used by SPSS, fixed-format ASCII data, and comma-delimited text files. 
 
In all cases, data are "imported" into IRTPRO (fixed-format input uses the Open command, 
but the effect is the same), and then re-saved as an IRTPRO system data (.ssig) file that is 
subsequently opened for analysis. 

1.1 Importing Data from SPSS .sav Files 
SPSS .sav files represent one example of many proprietary formats from which IRTPRO can 
import data.  
 



To begin the data-import process, one starts IRTPRO and selects Import… under the File 
menu: 
 

 
 

This brings up a standard Open File dialog; in the lower center is a pop-up menu from which 
the user may select one of a large number of formats. 

 
 



Here we select SPSS Data File (*.sav); then, after navigating to the folder that contains 
the .sav file from which we wish to import data, we Open the file: 
 

 
The next thing that happens is a standard Save As dialog appears, which has as its default to 
save the data as a .ssig file with the same name as the .sav file (in the case of this example, 
Asthma_34). 

 
The user may (optionally) change the first part of the name; however, the extension should 
remain .ssig. Click the Open button to start the data import process. 
 

 



 
After one clicks Save the file is saved as an .ssig file, and the user has the opportunity to 
Open it to begin the analysis: 
 

 
 
If one clicks Yes, the file opens.  
 
A very important first thing to do the first time a new .ssig file is opened, is to enter missing 
the code that represents missing data in the dataset. This code must be numeric; there can 
only be a single missing data code, common to all of the items; and the missing data code 
cannot also be a valid item response code for any item. For data coded 0, 1, 2, 3, …, it is 
common to use -9 as the missing value code. Note that the default missing value code in 
IRTPRO is -1.  
 
To set the missing value code, select the Missing Value Code… entry under the Data menu: 
 

 
 
That brings up a Missing Value Code dialog into which the user may enter the code, and click 
on OK. 

 



 
After that is done, it is important to Save the .ssig file: 
 

 
 

Once the missing value code has been set, and the .ssig file has been saved, the missing data 
code will be stored within the .ssig file and IRTPRO will "remember" the code in subsequent 
uses of the data. 
 
The file is now ready, and the user may proceed with analyses as described in Chapters 4 to 
5. 

1.2 Opening Fixed-Format Data Files 
To bring in data from a fixed-format file, there is a slightly different procedure. It begins 
with the Open option under the File menu: 
 

 
 
which brings up a standard Open dialog. In the lower center of this dialog, the user selects 
Fixed Format Data (*.fixed) from the pop-up menu, identifying Files of type: 



 

Then one opens the file; here we use as an example the file simul5.fixed stored in the folder 
IRTPRO Examples\By Dataset\Simulated. The data consists of five multiple category items. 
The simulated data represents 1000 examinees drawn at random from a population with 
mean ability score of 0.0 and standard deviation of 1.0. 
 

Note that it is necessary that the fixed-format data file has the extension .fixed. 

 

 
 



After the user clicks Open, an image of the file appears on the screen: 
 

 
In the file simul5.fixed there is a Case Number variable in columns 1 to 4 (its values are 0001 
to 1000), and item responses for five items, each of which is in a one-column field, in 
columns 7 to 11. To bring those data into IRTPRO as an .ssig file, the user must indicate the 
division of the file into (sets of) columns, or Fields, and assign names to the variables. 
 
To indicate that columns 1 to 6 should be separated from columns 7 to 11, the user double-
clicks between the small 6 and 7 in the gray column-header; after that is done; a vertical line 
appears between columns 1 to 6 and the subsequent columns: 
 



 
 
After that is accomplished, there is a small rectangular box above the column-header 
numbers 1 to 6. A right-click within that box brings up a menu within which the user selects 
the entry Field Property … to give a name to this Field: 
 

 
 
In this case, the Field (columns 1 to 6) contains the data for the Case Number variable, so we 
give it the label Case Number, and click OK: 
 



 
 
Then we move to the right, and double-click between the column headers 7 and 8; then 8 and 
9 then 9 and 10; and then 10 and 11 to get the vertical separation lines shown below.  
 

 
 
Once this is done, we right-click on the empty gray rectangle above the column heading 7; 
that again brings up the Field Property dialog. In this case, we enter the label Item1 and click 
OK: 
 

 
 
Repeat this procedure by right-clicking, in turn, on the empty gray rectangles above the 
column headings 8, 9, 10 and 11 and enter the item names Item2, Item3, Item4, and Item5 
respectively.  



 
 
Once the OK button is clicked (see image above) after entering the last item name, each 
rectangle will be marked by an * symbol, and the File menu becomes active. We select Save 
as IRTPRO Data File from the File menu: 

 

 
 
This brings up the standard Save As dialog, and we save the file as Simul5.ssig (or whatever 
name we might prefer, with the extension.ssig): 
 



 
 
In this case, unlike when the Import option is used, the new .ssig file opens immediately. 
 

 
 
It is important to remember to set the Missing Value Code, if there are missing values in the 
data, as described in the previous section: 
 



 
 
 

Importing space delimited fixed-format files 

If there are spaces between the columns in a fixed format file, one can import the file directly 
if the file is saved with an extension .txt. As an illustration, consider the same simulated 
dataset used above, but in this instance saved with spaces between each variable: 
 

 
 
Use the File, Import option and select files of type (*.txt, *.csv). Browse for the file 
simul5it.txt stored in the folder IRTPRO Examples\By Dataset\Simulated and click the Open 
button: 



 
 
This action will prompt the user to save the IRTPRO data file: 
 

 
 
 A portion of this file is shown below.  
 



 
 
The default column names are Col1, Col2,… . To rename, use the Data, Variable Properties… 
option.  
 

1.3 Importing Comma-delimited Data 
Comma-delimited .csv files represent another commonly used format from which IRTPRO 
can import data. While it is possible that IRTPRO will not properly open certain types of 
Excel ".xls" worksheet files, Excel will also save data as comma-delimited, and that can be 
used if the data are in an Excel-readable format. While tab- or space-delimited data are also 
commonly used, IRTPRO cannot currently open those files. However, one can use a text 
editor to change tabs to commas, and then one has a comma-delimited file that IRTPRO can 
open. 
 
To begin the data-import process, one starts IRTPRO and selects Import… under the File 
menu: 
 



 
 
This brings up a standard Open File dialog; in the lower center is a pop-up menu from which 
the user may select one of a large number of formats: 
 

 
 
Here, we select ASCII File – Delimited (*.txt,*.csv). 
 
Then we navigate to the folder that contains the .csv file we wish to import, and Open it: 
 



 
 
In this case, as an example, we are using the file Anger6IT.csv which contains the same data 
as the Anger6IT.fixed file used in the previous section, except that the data in Anger6IT.csv 
are comma-delimited, one line per observation, instead of in fixed columns. When we Open 
the file, a standard Save As dialog appears 
 

 
 
and we Save the file as Anger6IT.ssig. After one clicks Save, the file is saved as an .ssig file, 
and the user has the opportunity to Open it to begin the analysis: 
 



 
 
If one clicks Yes, the file opens.  
 
It is again important to remember to set the Missing Value Code as described in Section 1.1.  
 

 
 

There are many other ways to "get data into" IRTPRO, but they are variations on the 
procedures described in this document. If you encounter difficulties opening a file of some 
particular format, please let us know. However, in the interim, a good work-around would be 
to re-write or save the file in one of the formats that IRTPRO does successfully read, and 
proceed from there. 
 

1.4 Data Manipulation: Data menu 

1.4.1 Introduction 

To demonstrate the data manipulation options available in IRTPRO, we use the dataset 
AnxietyItems.ssig. To see the data, use the Open file dialog under the File menu, navigate to 
the C:\IRTPRO Examples\By Dataset\Anxiety14 folder, select Files of type: IRTPRO Data File 
(*.ssig) in the Open File dialog, and open the file AnxietyItems.ssig. There are eight variables 
and the first ten cases are shown below.  
 



 
 
If the spreadsheet is the current window, the main menu bar displays the Data, Manipulate, 
Graphics and Analysis options. The list of available options from the Data drop-down menu 
is next. 

 

 

1.4.2 Delete variables or cases 

Selection of the Data, Delete Variables… option provides the user with access to the Delete 
Variables dialog. In the following demonstration, the variables V13 to V14 are deleted by 
selecting the Delete from: drop-down list and then the Delete to: drop-down list. 
 

 
 
By clicking the OK button, the revised spreadsheet is displayed. These changes have not 



been made to the original data yet and therefore an asterisk (*) sign is appended to the file 
name, as shown in the top pane of the IRTPRO window. Use the File, Save option to make the 
changes permanent. 
 

 
 
To delete cases from the data, select the Data, Delete Cases… option and make the required 
selections  using the Delete Cases dialog. 
 

 

1.4.3 Renaming Variables 

Next, we would like to rename the variable names Item1 to Item6. These names are to be 
replaced by Calm, Tense, Regretful, AtEase, Anxious, and Nervous. Select the Variable 
Properties… option from the Data menu to activate the Properties dialog. 
 

 
 
Starting with Item1 in the Name: drop-down list, click the Rename… button and change the 



name to Calm (see the two dialogs below).  
 

 
 

 
 
Click the OK button to return to the Properties dialog. Repeat the above procedure for Item2 
to Item6.  



 
 
Once the last variable has been renamed by using the Variable name text box, click the OK 
button to return to the Properties dialog. 
 

 
 
When the Properties dialog is displayed, use the OK button to display the revised spreadsheet 
and then use the File, Save option to make the changes to AnxietyItems.ssig permanent. 
 

 



1.4.4 Missing value code 

To set the missing value code, select the Missing Value Code… entry under the Data menu: 
 

 
 
That brings up a Missing Value Code dialog into which the user may enter the code (-1 is the 
default, but is also the code for this data) and click on OK. 
 

 
 
After that is done, it is important to Save the .ssig file by using the File, Save option. Once 
the missing value code has been set, and the .ssig file has been saved, the missing data code 
will be stored within the .ssig file and IRTPRO will "remember" the code in subsequent uses 
of the data. 

1.4.5 Insert variables or cases 

Suppose that we want to insert two new variables into AnxietyItems.ssig before the item 
Calm and then rename the new variables to SumScore and CalmRecoded. To proceed, select 
the Data, Insert Variables… option. 
 



 
 
Selection of this option activates the Insert Variable(s) dialog. Make the selections shown 
below and click OK. 
 

 
 
The revised spreadsheet is displayed with default variable names VAR0 and VAR1 and with 
all the corresponding data cells filled with the missing value code. Use the File, Save option 
to make the changes to AnxietyItems.ssig permanent. 
 

 
 
Rename VAR0 to SumScore and VAR1 to CalmRecoded. 

  



  

1.5 Data Manipulation: Manipulate menu 
Currently, the only option available from the Manipulate menu, is the Recode… option as 
shown. This option is selected in what follows. 
 

 

1.5.1 Recoding item scores 

Suppose, for example, that we want to define a new variable called CalmRecoded by 
combining the fourth and fifth categories of the item Calm. In Section 1.4.3 the Properties 
dialog showed that the five distinct values of Calm are 1, 2, 3, 4, and 5. Therefore, we want to 
recode these values so that, for the new variable CalmRecoded 5 = 4 and all the remaining 
data values remain unchanged. This recoding is accomplished by selection of the Manipulate, 
Recode… option to invoke the Data Manipulation window. 
 
When using the if ( ) statement, follow the next rules: 
 
Click with mouse pointer within the (  ) brackets, then double-click on Calm or drag Calm to 
within the (  ) brackets. 
 
Click on the appropriate operator from the following list: 
o <     (Less than) 
o <=    (Less than or equal to) 
o >=    (Greater than or equal to) 
o >     (Greater than) 
o !=    (Not equal to) 
o ==  (Equal to, see usage below)  

 



 
 
Click OK, then save the data file and select Data, Properties… from the main menu bar to 
verify that CalmRecoded has four categories. 
 

 



1.5.2 Calculating the sum of two or more variables 

Suppose that the new variable SumScore equals the sum of the six items, CalmRecoded and 
Tense to Nervous. In the illustration below we used three statements. After the first statement 
is entered, use the Enter button to advance to the next line. Variables are entered onto the 
Compute window by either double-clicking or dragging.     
 

 
 
Click the OK button and use the File, Save option to make the changes to the file 
AnxietyItems.ssig permanent. The distribution of the SumScore values is shown below. 
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